Thursday, December 2, 2021

Heathkit IG-37 FM Stereo Generator and Weekly Recap

 Hope you all had a Happy Thanksgiving last week. We went to the clan's homestead way up in the canyons, did some shooting, and had a great gathering. I got to shoot a Marlin "Saddle Gun" in 45-70 Gov't, and it took a day for my shoulder to recover.  The Chevy Colorado did fine going up the "road", and I used 4WD Hi Range going up, and Lo Range coming down. Coming down you rarely exceed 20MPH, so Lo Range was fine.

So, back to the generator. This is it after I finished it. The big shiny can on the chassis is a new power supply filter I bought from Hayseed Hamfest, one of the only places you can get new manufacture "can" type electrolytic capacitors for vintage tube equipment. They're great people, and I've been buying new cans from them for quite a while.


 And the bottom view. Some new parts visible, while the rest are OEM.


 This started out as a simple capacitor replacement, checkout, and calibration. First, I tightened all the loose hardware. And I mean all of it. It was full of loose hardware, both holding things down, and providing ground returns on the tube sockets and terminal strips. Replacing the old parts showed the soldering was not up to standards. Some things had solder globbed on them, some had cold, grainy looking connections, and three connections were barely soldered. Cleaning that up took most of a day. This in NOT one of the better assembled kits I've seen, and while it may have "worked" in 1967, it would have caused problems today.

After replacing the parts, I did the initial checks, and started the calibration. Then the problems appeared. One of the waveforms was "clipping", which meant the tube wasn't operating in it's Linear Region, and it looked to me like it was biased wrong, as only one part of the waveform showed the clipping. So, I started checking the resistor values that set the bias, and found several resistors that were out of tolerance, and replaced them. No change. I replaced several coupling capacitors between stages, as if they get leaky, and pass DC voltage, they can throw the bias voltage to the following stage off. No change, again. These are pretty simple circuits, and it was starting to drive me batty., so I dropped back to the basics, and started checking the voltages. BINGO! ALL the "B+" (aka "Plate Voltage") voltages were way off. Where there was supposed to be 134 Volts, there was 119 Volts. Where there was supposed to be 120 Volts, there was 90 Volts. The problem was in the power supply section, something I normally checked, and since I had replaced the main filter capacitor, what could be the problem? Hey, Jim! Did you check the only resistor in the power supply? Uhhhhhh....no.

Turns out the 330 Ohm dropping resistor had increased in value to 560 Ohms, and was dropping excessive voltage. This was a 2 Watt resistor, and it was dissipating about 1.5 Watts, which is too close to it's ratings. Over the years, the heat took it's toll (common issue with Carbon Composition resistors), and it drifted high in value. I changed it out for a 5 Watt rated part, and all the voltages returned to normal. The alignment/calibration went per the book, but I don't like the way some of the adjustments acted when I was doing them. I put it back on the shelf, and I'll let it sit for a while, and redo the alignment. It might have another problem, or I might be doing it wrong.

Next up was another Heathkit. an IM-5238 AC Voltmeter.

 This is all solid-state, so heat aging of the filter capacitors and other parts isn't much of an issue, and all the power supply voltages were spot-on, and looking at the DC with my scope showed no discernible ripple.

But it failed step two of the calibration. I started poking around in the circuit, flushing out the adjustment pots with alcohol, and measuring them. One of them looked "funny", so I pulled both out of the circuit board to test them. They measured to specs, so I went to put them back in. I noticed the one I was having trouble with didn't properly seat on the board, and it's leads just barely came through the board, making one connection almost impossible to properly solder. I pulled it back out, cleaned the pads on the board, and ran a small drill bit in a pin vise through the mounting holes. Mounting it back on the board allowed the leads to go through the holes all the way, and I could properly solder it to the board.

PRESTO! All the adjustments worked, and the calibration went per the book. Since calibrating this instrument requires tack soldering some jumpers in place, and this unit showed no signs of it being done, this might be a "Never Worked" kit that was built and set aside. -OR- it was soldered "just good enough" to work, and never properly calibrated. Anyway....it's fully functional, and back on the shelf.

Now to get to this pile:

This is a Low Distortion Audio Signal Generator, an Harmonic Distortion Analyzer, and an Intermodulation Distortion Analyzer. When these have been gone through I should have a nice set of audio test equipment.


8 comments:

  1. Nice job!! My dad built heathkits, and I'm an electronic tech in the calibration field. Been getting back into vintage audio gear lately. Cheers!

    ReplyDelete
    Replies
    1. All my "real" test equipment has current calibration, so I can measure frequency, voltage, current, etc with more than acceptable accuracy. My big HP signal generator is also calibrated, so I can generate accurate frequencies and levels.

      Calibrating this old Heathkit gear with current instruments can give it a new lease on life.

      Delete
  2. I started to build a Heathkit oscilloscope back in the 70s and never finished it. I gave it to Ed, WA6AKJ (SK) who promptly got it working. I told him to just keep it in his shop which he did.

    ReplyDelete
    Replies
    1. I never built a scope. I didn't even own a decent one until I bought an HP at the TRW swapmeet.

      Now I have a nice Tek 2465B 400MHz one with a built-in counter and voltmeter.

      Delete
  3. Patience is a virtue, as you continue to prove... :-)

    ReplyDelete
    Replies
    1. I'm a little red-faced over spending a whole week putzing around on the stereo generator, but you're right. I stuck to it and fixed it.

      Delete
  4. One of the many things I like about this blog is that it's uplifting. OK, I don't understand the tech very much but it's good to see projects started and brought to completion. Nice.

    Then there's 45-70... I'm thinking a 30-30 lever might be more my shoulder speed :)

    ReplyDelete
    Replies
    1. Thank you, Parson. It helps keep my mind sharp, my fingers nimble, and distracts me from all the turmoil going on by doing something productive.

      Before The Tragic Boating Accident happened, I had a Marlin 336 in 30-30. It's a sweetheart of a rifle, with very moderate recoil, and more accuracy than I can use. The Hornady LeverEvolution rounds make it a practical 150 yd rifle.

      Delete

Keep it civil, please....

Pioneer CT-F950 Reel Motor Rebuild

 As I mentioned yesterday, the first electrical issue I ran across in rebuilding this deck is that it kept dropping out of Play. A bit of sl...